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About MARC/Hexmesh

Advantages of MARC/
HexMesh

MARC/Hexmesh generates a hexahedral mesh automatically 
from your CAD geometry enabling you to move rapidly from a 
CAD model to a finite element model of even the most complex 
shapes. 

A model generated with MARC/Hexmesh allows you to 
perform linear and nonlinear finite element analyses and to 
achieve the kind of quality results associated with finite element 
models composed of hex elements. 
 

hexahedra l  e lements generated by MARC/HexMesh
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About MARC/Hexmesh

Advantages of 
Hexahedral Elements

A mesh with hexahedral elements is generally more accurate 
and requires fewer elements than a meshes that contains 
tetrahedral elements. For complex geometries, hexahedral 
meshes are easier to visualize and edit than tetrahedral meshes. 

Activating the MARC/
HexMesh Feature

MARC/HexMesh is an add-on feature. If you purchased 
MARC/HexMesh with your original purchase or license 
renewal, your license file includes the feature line, HEXMESH 
which activates MARC/Hexmesh. 

If you wish to purchase MARC/HexMesh for an existing 
license, contact your local MARC office. You will receive an 
additional feature line for your license file from 
license@marc.com. 

in ter ior  o f  model  meshed with MARC/HexMesh
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About the Hexmesh 
Menu in Mentat

Use the Hexmesh menu in Mentat to define the parameters and 
apply the commands for the MARC/HexMesh. To display the 
Hexmesh menu, choose Mesh Generation>Automesh>Solid 
Meshing

About the Input for 
MARC/HexMesh

The MARC/Hexmesh takes a description of a surface that is 
based on 3- or 4-node elements and performs an edge detection 
and a hexahedral mesh generation on that surface.

Before you apply the MARC/Hexmesh, you should create a 
surface mesh of the volume to be meshed. This volume should 
be totally enclosed with no free edges or ‘torn seams’. The 
surface mesh   serves as a bounding surface of the volume to be 
meshed. 

Mesh Generat ion>Automesh>Sol id  Meshing

parameters

commands
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Key Steps in the 
Meshing Process

Here are the key steps in the meshing process:

You can regulate the accuracy and speed of the hexmeshing 
operations by specifying the different parameters and applying 
the Hexmesh commands in Mentat.

Create a surface
mesh with 3- or 4-

node elements

Check to ensure
that the outline
length of the

surface mesh is
zero

Select the
appropriate

parameters for the
hexahedral mesh

Need to verify
edges?

Invoke edge
detection

command and edit
edges if necessary

Apply MARC/Hexmesh

Yes

No

Note:
You may need to use the
SWEEP command to remove
coincident nodes.

Note:
You can use any of the
following surface meshers in
Mentat:
ì Delaunay
ì Advancing Front
ì Overlay

Note:
Use the Hexmesh menu in
Mentat to define the
parameters.

Note:
Selected edges
are considered to
be "real" edges.
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Questions or 
Comments About 
MARC/HexMesh

If you have questions and comments about MARC/HexMesh, 
or you need more information, use the following table to reach 
us:
 

for... contact...

technical support 
information about MARC/
HexMesh,

support@marc.com

questions and comments 
about this user guide,

document@marc.com

revisions of this user guide 
in Portable Document 
Format (you need Acrobat 
Reader 3.0 or higher),

http://www.marc.com/
Support/Support.html

http://www.marc.com/Support/Support.html
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Using Parameters and Commands

Specifying Element 
Size

Use the Element Size parameter to specify the sizes of 
hexahedral elements generated in the x, y, and z directions. The 
default element sizes for the x, y, and z directions are 0.1.

The size of the element determines the number of resulting 
hexahedral elements. The following table demonstrates how 
element size affects the meshing process:

To set the element size:

1. Click E L E M E N T  S I Z E .

2. Type the element sizes in the x, y, and z directions. You 

must specify an element greater than zero.

3. Press Enter.

If you specify... then...

smaller elements, the quality of the mesh is better. 
However, since there are more 
elements, the meshing process is 
slower. Also, if you specify too 
small an element size, the 
meshing grid may become too 
large and the mesher may fail.

a large element size 
(in comparison to the 
object size),

meshing might fail.

Mesh Generat ion>Automesh>Sol id  Meshing
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Using Parameters and Commands

Specifying Edge 
Sensitivity

Use the Edge Sensitivity parameter to specify when, in the edge  
detection process, the shared edge between two input elements 
represents a "real" edge. The mesher uses these real edges to 
maintain the geometric representation of the model. 

A higher value of edge sensitivity makes the HexMesh more 
sensitive during the edge detection process. The default value of 
edge sensitivity is 0.5. The range of values is 0 < x < 1.

How the Value of Edge 
Sensitivity Affects the 
Edge Detection 
Process

The following illustrations show how the value of edge 
sensitivity affects the edge detection process:

• Edge sensitivity = 0:

Mesh Generat ion>Automesh>Sol id  Meshing

fewer edges detected
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Using Parameters and Commands

• Edge sensitivity = 1:

To specify edge sensitivity:

1. Click E D G E  S E N S I T I V I T Y  and type in a value.

2. Press Enter.

Specifying Gap Use the Gap parameter to specify the size of the gap that is 
initially left between the inner hexahedral elements and the 
surface during mesh generation. 

After the mesher creates the overlay grid it removes elements 
that are either close to or outside the surface mesh depending on 
the value of the gap that you specify. The mesher then meshes 
the gap area. 

The range of values for the Gap parameter is -1 to 1. Negative 
values result in a smaller gap and can even result in mesh 
penetration. 

To set the value of the Gap parameter:

1. Click G A P  and type in a value.

more edges detected
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Using Parameters and Commands

2. Press Enter.

How the Value of Gap 
Affects the Mesh

The following figures demonstrate how the value of gap affects 
the mesh.

• Gap set to -0.3:

• Gap set to 0:
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Using Parameters and Commands

How the Value of Gap 
Affects the Mesh 
(Contd.)

• Gap set to 1:

Specifying the Number 
of Shakes

Shaking is a process of global mesh enhancement where the 
nodes tend to move to places of less potential energy. This has a 
relaxing effect on the nodes and often results in a better mesh 
quality. 

Higher values of the Shakes parameter take up greater 
computing resources. Here are some guidelines for setting the 
values of the Shakes parameter for test and final meshes:

To specify the number of shakes:

1. Click S H A K E S  and type in a value.

2. Press Enter. 

Situation Suggested Value

Test mesh 10

Final mesh 100
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Using Parameters and Commands

Using the Runs 
Parameter

If the HexMesh does not produce a valid mesh, it can 
automatically run again with a smaller element size. Using the 
Runs parameter, you can specify the maximum number of 
reruns performed by the HexMesh.

To specify the number of runs:

1. Click R U N S  and type in a value.

2. Press Enter.

To prevent reruns, type in the value, 1.

Using the Coarsening 
Parameter

Use the Coarsening parameter to specify a difference in size 
between the elements in the interior and the elements in the 
surface. This may reduce the overall number of elements 
generated. 

You can specify one of three levels of coarsening—0,1, or 2. A 
value, 0, indicates that there will be no coarsening. A value, 2, 
specifies that the elements in the interior can be up to four times 
larger on each side than the elements on the surface.

To specify a level of coarsening, click on the radio button next 
to the level.

Mesh Generat ion>Automesh>Sol id  Meshing

Mesh Generat ion>Automesh>Sol id  Meshing



MARC/HexMesh: User Guide 19

M
A

R
C

/H
exM

esh
 P

aram
eters an

d
 

C
o

m
m

an
d

s
Using Parameters and Commands

How the Level of 
Coarsening Affects the 
Elements

The following illustrations represent two different levels of 
coarsening.

• Coarsening set to 0: 

• Coarsening set to 2: 

in ter ior  e lements of  the model are uni form 

in ter ior  e lements are larger  than the e lements on the sur face 
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Using Parameters and Commands

About the Local 
Enhance Parameter

The Local Enhance parameter checks for inside-out elements in 
localized areas of the final mesh. If there are inside-out 
elements in certain localized areas, the mesher checks those 
elements for any additional constraints (for example, they may 
be mapped on to corner points or edges). 

When it finds additional constraints in the inside-out elements, 
the mesher removes the constraints so that the resulting mesh in 
those areas has no inside-out elements.

The default setting of the Local Enhance parameter is ON.

Using the Allow 
Wedges Parameter

Use the Allow Wedges parameter to create wedge elements if 
an edge crosses the diagonal of a face of the hexahedral 
element. This improves the quality of the resulting mesh.

• Allow Wedges parameter OFF: 

Mesh Generat ion>Automesh>Sol id  Meshing

no wedges
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Using Parameters and Commands

• Allow Wedges parameter ON.

About the Coons 
Patches Parameter

Use the Coons Patches parameter to reduce the loss of volume 
while meshing regions with curved surfaces. This results in a 
smoother representation of the input surfaces and a better 
approximation of the input geometry. However, this parameter 
consumes greater CPU resources. 

The default setting for the Coons Patches parameter is OFF. 

Using the Detect 
Edges Command

Use the Detect Edges command to automatically select 
geometric edges from an input list of triangular and 
quadrilateral elements that enclose the volume to be meshed. 
These detected edges help define the input geometry for the 
MARC/HexMesh.

 with wedge elements

Mesh Generat ion>Automesh>Sol id  Meshing
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Using Parameters and Commands

The elements in the input list should be oriented with their tops 
facing outward and there must not be any free edges or holes in 
the list. 

To apply the Detect Edges command:

1. Click E D G E  S E N S I T I V I T Y  and specify a value other than 

0.

2. Click D E T E C T  E D G E S  and enter a list of triangular or 

quadrilateral elements.

3. Press Enter.

When you apply the Detect Edges command, the detected 
element edges are automatically included in the list of selected 
edges. However, you can modify this list by selecting (or 
deselecting) edges before applying the HexMesh command.

Selecting Edges To select edges:

1. Choose Mesh Generation>Select.

2. Choose the select mode, A N D .

3. Enter a list of edges.

4. Press Enter. 

Deselecting Edges To deselect edges:

1. Choose Mesh Generation>Select.

.

 
Any element edges that you select using the Detect Edges
command are considered to be real edges. 

To remove these edges, clear them from the selection list
using the Select menu options in Mentat (see Deselecting Edges). 
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Using Parameters and Commands

2. Choose the select mode, E X C E P T .

3. Enter a list of edges.

4. Press Enter.

Checklist for the 
Hexmesh Command

Before you apply the Hexmesh command you should ensure 
that:

• the input list of triangular and quadrilateral elements 

enclose the volume to be meshed.

• there are no free edges or holes in the input list.

• the elements are oriented with their tops facing outward

• the length assigned to the element edges does not exceed the 

thickness of geometry to be meshed (a good rule-of-thumb 

is: edge length = 1/3 thickness of the smallest section)

Applying the Hexmesh 
Command

To apply the HexMesh command:

1. Click H E X M E S H

.

2. Specify a list of triangular and quadrilateral elements. 

3. Press Enter.

Mesh Generat ion>Automesh>Sol id  Meshing
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Using Parameters and Commands

About the Meshing 
Tools

The following table describes the operations supported by 
meshing tools available for the hexmesher:

Rectifying an 
Unsuccessful 
Hexmeshing Operation

If your hexmeshing operation is unsuccessful, here are some 
measures that you can take before running the operation again:

• In the static menu area, click U N D O  to return to the input 

mesh. 

• Check the detected edges and edit them if necessary (See 

“Using the Detect Edges Command” on page 21).

• Select a gap parameter value other than 0 (See “Specifying 

Gap” on page 15). 

• Specify a different element size (See “Specifying Element 

Size” on page 13).

• Modify the input list.

Tool Operation

Outline Edge 
Length

Computes the outline edge length. 
A value, 0, signifies that there are:

• no free edges
• all elements have the same orien-

tation

Sweep Outline 
Nodes

Removes coincident nodes on the 
outline.

Check Mesh Checks mesh for distorted, 
upside-down, or inside-out 
elements. Reverses the orientation 
of elements, curves, and surfaces.

Clear Mesh Removes the entire mesh leaving 
the geometry intact. 
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Using Parameters and Commands

• Check the Mentat shell window for any status, warning, and 

error messages:

Mentat  shel l  window
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Using MARC/HexMesh

About the Example The meshing example in this chapter demonstrates the steps in 
meshing a solid model with MARC/HexMesh. The example is a 
procedure file, hexmesh.proc, and uses the model, hexmesh.mfd. 

The procedure file and the model are located in the Mentat 
directory, examples/userguide. 

Example Overview The key stages in this example are:

• Stage1: Run the procedure file.

• Stage 2: Prepare the input model for surface-meshing using 

the Delaunay surface tri-mesh.

• Stage 3: Apply the Delaunay tri-mesh

• Stage 4: Prepare the input list for MARC/HexMesh using the 

HexMesh parameters

• Stage 5: Apply MARC/HexMesh
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Using MARC/HexMesh

Running the 
Procedure File

To run the procedure file, hexmesh.proc:

1. Choose Utils>Procedures.

2. In the Mentat Procedure Control window, click L O A D .

3. In the Mentat Procedure Files window, locate the file, 

hexmesh.proc, in the directory, examples/userguide.

4. Click O K . The procedure file appears in the Mentat Proce-

dure Control window.

5. Use one of the following options to run the procedure file:

• To run the procedure file without interruptions, click 

S T A R T / C O N T .

• To run the procedure file step by step, click S T E P .

Preparing the Model 
for Surface Meshing

To prepare the model for surface-meshing using the Delaunay 
surface tri-mesh:

1. Click F I L L  to make the entire model visible.

2. Click D R A W  and turn the drawing of nodes and points to 

OFF.

run procedure f i le 
without  in ter rupt ions

press to  s top or  
pause f i le

run procedure f i le
step by s tep



MARC/HexMesh: User Guide 31

U
sin

g
 M

A
R

C
/H

exM
esh

—
E

xam
ple

Using MARC/HexMesh

Preparing the Model 
for Surface Meshing 
(Contd.)

3. Choose View>View Status>Show View 4.

4. Click Mesh Generation>Automesh>Remove Free Curves to 

remove curves not attached to the surface.

5. Click B R E A K  C U R V E S  and specify:

•  a vertex tolerance (0.5)

•  a list of curves (all existing)

6. Clean the surface geometry by specifying the following tol-

erance settings:

• minimum tolerance (.01)

• surface parametric space tolerance (.01)

7. Click C L E A N  S U R F A C E  L O O P S  and specify a list of sur-

faces (all existing).

8. Click C H E C K  S U R F A C E S  and specify a list of surfaces (all 

existing).

9. Choose Automesh>Curve Divisions>Type

10.  Specify a curve division with fixed average length (1).

v iew 4
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Using MARC/HexMesh

Preparing the Model 
for Surface Meshing 
(Contd.)

11.  Click A P P L Y  C U R V E  D I V I S I O N S  and specify a list of 

curves (all existing).

12.  Click M A T C H  C U R V E S  and specify:

•  a vertex tolerance (.05)

•  a list of curves (all existing)

curves matched
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Using MARC/HexMesh

Applying the Delaunay 
Tri-mesh

To apply the Delaunay tri-mesh to the model: 

1. Choose Surface Meshing>Surface Tri Mesh.

2. Specify a list of curves (all existing).

Preparing the Input 
List for MARC/
HexMesh 

To prepare the input list for MARC/HexMesh:

1. Sweep any extra nodes by specifying:

• a sweep tolerance (.05)

• a list of nodes to sweep (all existing)

2. Click P L O T  and change the following plot settings to view 

the mesh more clearly:

• Set the drawing of curves and surfaces to OFF.

• In the Elements areas, click S O L I D  to display the element 

faces in solid color.

sur face t r i  mesh appl ied
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Using MARC/HexMesh

Preparing the Input 
List for MARC/
HexMesh 

3. Click R E D R A W  to redraw the model with the new settings.

4. Choose Main>Mesh Generation>Automesh>Solid Mesh-

ing.

5. In the Hexmesh area, C L I C K  E D G E  S E N S I T I V I T Y  and 

specify a value (.5).

6. Click D E T E C T  E D G E S  to identify the geometric edges in 

the triangular elements and specify a list of edges (all exist-

ing).

7. Choose Main>Visualization>Colors>Select Edges

8. Change the selected edge color by specifying a colormap 

number (23 1 0.6 0). 

9. Choose Main>Mesh Generation>Automesh>Solid Mesh-

ing.

10.  Click E D G E  S E N S I T I V I T Y  and specify a higher edge 

sensitivity (.6).

11. Click D E T E C T  E D G E S  again and specify a list of edges (all 

existing).

12.  Click E D G E  S E N S I T I V I T Y  and set the edge sensitivity 

even higher (.7) to detect more edges. 

13.  Specify a list of edges (all existing).

14.  Zoom in on the model and pick a few more edges (for spe-

cific edges, See “Procedure File” on page 37).

15.  Click F I L L  V I E W  to make the entire model visible. 

16.  Rotate the model, zoom in, and pick a few more edges (for 

specific edges, See “Procedure File” on page 37).
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Using MARC/HexMesh

Preparing the Input 
List for MARC/
HexMesh (Contd.)

17.  Rotate the model again to ensure that you picked all the 

edges. 

18.  Click R E S E T  V I E W  to reset the view to its original state.

19.  Click F I L L  V I E W  to make the entire model visible again.

edges p icked
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Using MARC/HexMesh

Applying MARC/
HexMesh

To apply MARC/HexMesh:

1. Choose Main>Automesh>Solid Meshing.

2. In the Hexmesh area, click E L E M E N T  S I Z E  and specify 

the element sizes in x, y, and z directions (.4, .4,.4).

3. Click H E X M E S H !  and specify a list of edges (all existing).

MARC/HexMesh appl ied
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Procedure File

About the Procedure 
File

The following pages describe the contents of the procedure file, 
hexmesh.proc.:

| Procedure file hexmesh.proc to demonstrate HexMesh in Mentat
open_model hexmesh.mfd
*fill_view
*set_points off
*set_nodes off
*show_view 4
*redraw
*fill_view
*rm_free_curves
*fill_view
*break_curves             
| Break the curves so you are able to have a conforming mesh
.05
all_existing
*set_mesh_min_tol
.01
*set_mesh_param_tol
.01
*clean_surface_loops
| Clean the loops in case there are some tiny curves or open loops
all_existing
*check_surfaces
| All the surfaces are okay
all_existing
*set_curve_div_type_fix_avgl 
*set_curve_div_avgl
1
*apply_curve_divisions
all_existing
*match_curves
| Ensure that divisions match up
.05
all_existing
*dt_surface_trimesh
| Now mesh the surfaces (Any mesher will do)
all_existing
*set_sweep_tolerance
| Don’t forget to sweep up those extra nodes
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.05
*sweep_nodes
all_existing
*set_curves off  
| Change some plot settings so we can appreciate our mesh
*set_surfaces off
*elements_solid
*redraw
*set_hexer_edge_sensitivity
| This is the default value
.5
*hexer_detect_edges
all_existing
*color 23 1 0.6 0
| Change the selected edge color to see them better
*set_hexer_edge_sensitivity
| Set the sensitivity a little higher to pick up more edges
.6
*hexer_detect_edges
all_existing
*set_hexer_edge_sensitivity
| Set it even higher to try to pick up more edges
.7
*hexer_detect_edges
all_existing                
*zoom_box
*zoom_box(4,0.086168,0.265903,0.258503,0.432570)
*select_edges
| Select a few more edges manually
 200:1
 1007:2
| Click on those edges twice to get both of them & avoid confusion
# | End of List
*fill_view
*zoom_box
*zoom_box(4,0.411565,0.576336,0.575964,0.730280)
 497:2
 922:2
 497:0  
| Get these edges over here, too...
 900:0
 520:2
 903:2
# | End of List
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*fill_view
*rot_model_cspace_z_for
| Now rotate to get a good look at the selected edges
*rot_model_cspace_z_for
*rot_model_cspace_z_for
*rot_model_cspace_z_for
*rot_model_cspace_x_for
*rot_model_cspace_x_rev
*rot_model_cspace_x_rev
*rot_model_cspace_x_rev
*rot_model_cspace_z_for
*rot_model_cspace_z_rev
*rot_model_cspace_z_rev
*rot_model_cspace_y_rev
*rot_model_cspace_y_for
*rot_model_cspace_y_for
*rot_model_cspace_y_for
*rot_model_cspace_y_for
*fill_view
*zoom_box 
| Here’s another edge to pick...
*zoom_box(4,0.804989,0.444020,0.917234,0.548346)
 627:0
 845:2
# | End of List
*fill_view
*rot_model_cspace_x_rev
| Rotate it around some more to be sure you are not missing any edges
*rot_model_cspace_x_for
*rot_model_cspace_x_for
*rot_model_cspace_x_for
*rot_model_cspace_x_for
*rot_model_cspace_x_for
*rot_model_cspace_x_for
*rot_model_cspace_x_for
*rot_model_cspace_x_for
*rot_model_cspace_x_for
*rot_model_cspace_x_for
*rot_model_cspace_x_for
*reset_view
*fill_view
*set_hexer_element_size 
| Now you are ready to apply the HexMesh
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.4 .4 .4
*hexer_hexmesh
all_existing
| Rotate it around and make some of those elements invisible 
| if you want to get a good look at the hex mesh.
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A
advantages

of hexahedral elements, 6
of MARC/HexMesh, 5

allow wedges parameter, 20
automatically selecting geometric edges, 21

C
check mesh. See meshing tools
clear mesh. See meshing tools
coarsening

levels of, 18
parameter, 18
specifying, 18

Coons patches
default setting, 21
parameter, 21

D
Delaunay surface tri-mesh, 29
deselecting edges, 22
detect edges

applying, 22
command, 21
in hexmeshing example, 34

detect edges. See also selecting edges

E
edge detection process, 14
edge sensitivity

default value, 14
parameter, 14
specifying in hexmeshing example, 34
specifying, 14

element size
parameter, 13
setting, 13
specifying in hexmeshing example, 36
specifying, 13

except mode, 23

G
gap

how it affects meshing, 16–17
parameter, 15
specifying, 15
value, 16

gap area, 15

H
hexahedral elements, 6
HexMesh command

applying, 23
requirements for input list, 23

Index
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Hexmesh menu
about, 7
displaying, 7
location of buttons, 7

hexmeshing example
applying the Delaunay tri-mesh, 33
changing the selected edge color, 34
displaying element faces in solid color, 33
drawing of nodes and points, 30
key stages, 29
making the entire model visible, 35
picking more edges, 34
preparing the input list, 33
preparing the model for surface meshing, 30
procedure file, 37
redrawing the model with new settings, 34
specifying a list of edges, 34

hexmeshing operation
error messages, 25
troubleshooting, 24

hexmeshing steps, 8

I
input list 23

orientation of elements, 22
inside-out elements, 20

L
levels of coarsening

choices, 18
effect on mesh, 19

license file, 6
local enhance

default setting, 20
parameter, 20

M
MARC/HexMesh

activating, 6
advantages of, 5
applying in the example, 36
checklist for, 23
example, 29
input for, 7
questions or comments, 9

Mentat Procedure Control window, 30
Mentat shell window 25
meshing tools

check mesh, 24
clear mesh, 24
outline edge length, 24
sweep outline nodes, 24
table of, 24

modifying an input list of edges, 22

O
outline edge length. See meshing tools

P
preventing reruns, 18
procedure file

running, 30
See also hexmeshing example
stepping, 30

R
real edges, 14
runs

parameter, 18
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S
selecting edges

about, 22
in hexmeshing example, 34

selecting edges. See also detect edges
shaking

guidelines for setting the values, 17
parameter, 17
specifying, 17
suggested values, 17

sweep outline nodes. See meshing tools

W
wedge elements, 20
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